1. RedOne_NL's Avatar
    THX Jerry,

    It works fine by me on a B+ with 0.7.0. I just see by another poster there is 0.7.1 Thx for that headsup.

    I am now using this project like a base for my own project. Still finding out new things in python but we will see. When the script is ready I will try to update another RPi and import my script.

    If people follow the steps everyone must be able to get it working i guess Dont forget to chmod files !

    Thx again. I hope you find the time to reply the questions in this topic because there are some that I also want to have an answer./

    Regards
    Ren
    05-09-2016 12:20 PM
  2. vjaykadam's Avatar
    Can you please let me know , what i need to do to use webippi with raspberry 3
    05-19-2016 09:02 PM
  3. Prasad067's Avatar
    Thanks Jerry, excellent post, very well explained! Got my first IoT project up and running😎
    05-24-2016 04:22 AM
  4. jepe63's Avatar
    Hi all, is there a way to make that the page refreshes automaticly ?
    06-09-2016 12:50 PM
  5. Raymond A's Avatar
    Hi!
    The problem is thath I have a Pi2 and then you got to patch the GPIO to get it to work. Searh for this:
    WebIOPi-0.7.1 Patch for Raspberry B+ and Pi 2
    When I am new I am not allowed to send links. But now its working for me. :-)

    For anyone having issues with the sudo /etc/init.d/webiopi start, this is your solution. I run on a RPi 3 and this fixed my problem
    07-08-2016 12:13 AM
  6. Barry914's Avatar
    Super article! I'm a total newbie to Pi, Raspian and a functional newbie to HTML and js, so I didn't have a clue to how to approach diddling the GPIO from a browser. You have provided a great foundation for me to expand on.
    08-18-2016 11:19 AM
  7. Barry914's Avatar
    Well, it appears I spoke too soon. I can load the page and the buttons change color when clicked but it doesn't control the GPIO. I also tried the WebIOPi utility which I should have tried first. I don't see a way to set up pins as input or output, and clicking a pin does nothing. Total newbie, not sure where to go next. Any ideas?

    How-To: Controlling GPIO pins via the Internet-capture.jpg

    (edit)

    Gets more interesting. I'm trying to run this on a Pi 3, but if I use the same image on the same Micro SD on a Pi Zero everything works as advertised. Now I am really confused.
    Last edited by Barry914; 08-18-2016 at 09:12 PM.
    08-18-2016 02:48 PM
  8. Barry914's Avatar
    I'm a total newbie and I'm kind of pulling my hair out trying to figure out how to show the current state of the GPIO outputs on the buttons when the page comes up. Can anyone help?
    08-21-2016 09:42 AM
  9. StevenWW's Avatar
    I had the same problem starting the daemon as a service after going through the tutorial. I just re-booted the Pi and then it worked. Don't know why.
    10-12-2016 03:38 PM
  10. Barry914's Avatar
    Turns out there are various articles on the web about this bug. Here's one: https://www.raspberrypi.org/forums/v...p?f=63&t=98981. Easy fix once you know what to do.
    10-12-2016 09:13 PM
  11. coombed's Avatar
    Evening all! So I found this awesome tutorial, I have followed it an have the system sucessfully opening and closing my garage door. Awesome stuff! Better still would be to have an MP3 play when the door opens - AC/DC, Back in Black, Iron Man Style! Any idea on how to do this? I can successfully write a python script to play an MP3 on the pi (see below) but I cant figure out how to attach this script to a button press.

    Cheers!
    Duncan

    (code:
    #!/usr/bin/env python

    import os

    os.system ('omxplayer /home/pi/Projects/Webio/Audio/Black.mp3')

    )
    10-20-2016 08:43 PM
  12. Barry914's Avatar
    Check out the webiopi documentation. You can create a button which calls a macro instead of controlling a GPIO pin.
    10-22-2016 09:55 AM
  13. Arturas Puodziunas's Avatar
    Wow, that works

    Many, many thanks
    Best wishes from Lithuania
    01-11-2017 03:26 PM
  14. hasseswe's Avatar
    Hi, im lost in space, cant create the icon on my phone, when i log in i get the pinout to cklick on and of for the right pin and thats works great
    But how should i do for change so i can get the icon on my phone
    i have the gpio.php file in /var/www/html/gpio.php
    02-06-2017 11:50 AM
  15. Rupesh sahu's Avatar
    thank you so much jerry
    i am building one car which runs from internet by using this technique


    thanks once again
    03-12-2017 04:04 AM
  16. Arjun p's Avatar
    GPIO doesnt responds to button press
    03-16-2017 06:06 AM
  17. edrftgyhuiot67rdfcvgbhjui78y6's Avatar
    The index.html file just says "Push button; receive bacon".
    This can't be right?!
    Any help appreciated
    04-06-2017 07:19 AM
  18. Vishal Sherathiya's Avatar
    It works fine. Thanks. But 1 question.
    How can I turn led ON/OFF using a regular html button?
    04-24-2017 08:49 AM
  19. paulpoco's Avatar
    In my previous post I said I had a raspberry pi running a webpage that stopped working on Android Chrome 59.

    Tried a few things.

    Installed Android Chrome Beta 60 and it doesn't work.

    Installed Android Chrome Dev 61 and it works.
    06-30-2017 10:14 PM
  20. thidev's Avatar
    Man, you are awesome... After many bugs on the way I made it. Thank you very much, I love it...
    07-30-2017 06:42 PM
  21. catchley's Avatar
    Getting 403 Forbidden error on the /img/LED-icon.png background. Any suggestions?
    10-23-2017 11:58 PM
71 123

Similar Threads

  1. Replies: 2
    Last Post: 05-29-2014, 12:26 AM
  2. Introduction to controlling GPIO pins with Python
    By Jerry Hildenbrand in forum Raspberry Pi
    Replies: 2
    Last Post: 05-21-2014, 01:40 AM
  3. Trusted device style security via Tasker
    By Teejai80 in forum Guides & How-To Articles
    Replies: 3
    Last Post: 05-03-2014, 06:17 AM
  4. Replies: 1
    Last Post: 04-28-2014, 07:39 PM
  5. Slow internet when bluetooth on
    By enigmax in forum Sony Smartwatch 2
    Replies: 9
    Last Post: 04-10-2014, 12:43 PM
LINK TO POST COPIED TO CLIPBOARD